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                                                                                             Introduction
The purpose of this guide is to show you how to install and use the SILVERRUN-RDM<->JAM application.

This application will let you transform specifications of a SILVERRUN-RDM schema to a JAM CASE Dictionary (JCD) file. You can also transform a JCD file into SILVERRUN schema. The bridge works with JAM version 7.

This product has 2 modes:

1. Forward Engineering (SILVERRUN-RDM -->JAM): to create CASE dictionary objects and repository entities in JAM, on the basis of SILVERRUN-RDM schemas.

The bridge converts Relational Data Model tables into the chain of JAM widgets of corresponding types,  relations between tables - into the JAM “Link” type widgets. JAM screen is generated on the basis of the description of each RDM subschema.

2. Reverse engineering (JAM-->SILVERRUN-RDM): to transfer updated CASE dictionary objects back to relational model SILVERRUN-RDM.

Figure 1 shows the interaction between SILVERRUN-RDM and JAM.
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Figure 1 
Data exchange between SILVERRUN-RDM and JAM
In order to ensure correct interaction with JAM, it is necessary to perform a number of operations in SILVERRUN-RDM:

·  generate Coded names for all objects of schema and project;

·  generate Base Types and Domains for JAM;

· using ODBC driver,  export schema and project in the chosen DBMS.

Any database, which has the ODBC driver, can be defined as DBMS. ODBC with the DBF file format is used to operate the bridge.

Note:
“SILVERRUN Enterprise RDM” version automatically stores RDM repository in Oracle DBMS.

Bridge in forward engineering mode transfers data from DBMS format to JCD (Figure 1.). You can access JCD directly from JAM.

The following types of objects are stored in JCD: subshema, table, column and relations between tables. These objects can be imported into JAM screens with  respective set of properties.

In RDM schema some properties of JAM widgets can be assigned by User-Defined Fields (UDF), provided by SILVERRUN-RDM. UDFs are automatically generated in SILVERRUN-RDM on the basis of description from the jam_sr23.typ file when generating Base Types (Generate Base Types and Domains...in the menu).  jam_sr24.typ file is used for SR-RDM version 2.4.

Before installing
This guide does not cover relational or conceptual modelling concepts, nor does it cover how to use JAM. You will have to consult the SILVERRUN-RDM and JAM documentation for specific reference on their use and functions.

Before you install SR-RDM<->JAM, you need to be familiar with the graphic interface used by your operating system. Make sure that your operating system and configuration are compatible with SR-RDM<->JAM.
Hardware Requirements
SR-RDM<->JAM requires a high-density disk drive and about 2,5 megabytes of free space on the hard disk. The operating speed of SR-RDM<->JAM depends on the speed of your processor and the memory available. Under Windows, the application requires at least an 80386SX processor and 8 megabytes of RAM.
Operating System Requirements
To operate the bridge, it’s necessary to have the following software, working under MS-Windows operating system:
· ODBC-drivers for DBF files.
Recommended driver for JAM:
“INTERSOLV Explorer dBASEFile”

                                                                            Installation Procedure
To install the Windows version:

1. Launch Windows.

2. Insert the original diskette in drive A or B.

3. Choose Run... from the Program Manager’s File menu.

4. In the Run... window, type:

x:setup - where “x” is either A or B depending on the disk drive your diskette is in.

5. Follow the instructions.

After installation you will need create 2 icons for the SR-RDM<->JAM Bridge application and JAM/CASEi for SR in JYACC group and copy jam_sr23.typ (or jam_sr24.typ) file into DBMS sub-directory of SILVERRUN.

Note: The ODBC driver of the Q+E v.1.1 product is necessary to work with the SILVERRUN and the bridge works with INTERSOLV Explorer dBASEFile (*.dbf) ODBC driver, which is included in the INTERSOLV Data Direct Explorer product.  
                    Forward Engineerig: From SILVERRUN-RDM to JAM
Data Model Construction in SILVERRUN-RDM
1. Load the Data Model to be transferred to JAM.

2. Generate Coded Names for all Schema and Project objects with the Generate Coded Names... function in the Project and Schema menu.

3. Then for project from SILVERRUN-RDM you must generate Base Types and Domains, corresponding to JAM types.

1) From the Project menu, select Generate Base Types and Domains...
2) Click on the Open... button in order to obtain the jam_sr.typ file that contains the necessary parameters.

3) Select the necessary options as shown on the Figure 2 and click on Generate.

Comment:
First option is for work with the Abbreviated Names.
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Figure 2
Base Types Generation screen for JAM

Switching on the last three flags is the common way for parameters configuration for most of the models. If UDF will not be used, the last flag can be switched off. Once generation is completed, you can see a list of Base Types for JAM using Base Types from Project menu.

Figure 3 shows a list of Base Types for JAM.
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Figure 3 
List of Base Types for JAM

In SILVERRUN-RDM, UDFs are automatically generated for Project and Schema concepts with the list of main JAM properties, as a result of base types generation (Figures 4,5).
Figure 4 shows UDF at Project level. You can get this list by using menu Project ->User Defined Fields.

Figure 5 shows UDF at Schema level. You can get this list by using menu Schema->Root->User Defined Fields.

User-Defined Fields allow you to transfer JAM-specific information from RDM. For example, text widget data formatting, color attributes or Status Line Text property, when focused on, can be defined by UDF. When transferring schema to JAM, the bridge converts these fields into the JAM widgets properties.
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Figure 4
Project User-Defined Fields for Domains
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Figure 5
Schema User-Defined Fields for Columns

Note:
You can also create any other JAM properties as additional UDFs. It’s possible to modify jam_sr.typ file or to create on its basis a file of descriptions with the other name. In this file you can define the default values. Since most of the properties values are automatically set by default in JAM, this function can be useful only to define the values different from those set by default in JAM. A list of the JAM Base Types can be modified in the same way.

4. Put the necessary values for the columns or domains into corresponding UDFs to specify widgets properties in JAM.

5. Export schema with subschemas to the format of the chosen DBMS:

1) make a connection to the database. Project information will be imported to, via the menu Util->DBMS->Connections... (at present .dbf (dBASE files) format is used);

2) create the database structure via the menu Util->DBMS->External Schema->Generate;
3) store the model in the database via the menu Util->DBMS->SAVE....

Note:
The function of building-up a database schema takes long time. When exporting several models from SILVERRUN, you can accelerate the process by copying database files into the directory associated with data source.

Procedure

Before starting the bridge SILVERRUN-RDM<->JAM under Windows, if necessary, create a new data source based on dBASE files ODBS driver.

1. Start SILVERRUN-RDM<->JAM. Click on appropriate icon in JYACC group.
2. From the File menu, select Forward Engineer.
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3. Select the appropriate type of names (name, coded name or alias) with the Descriptor Used from the options menu.
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4. Click on the Validation... button to validate your model (see the Validation section in this document for more information on this function).

5. If your model is valid, click on the Generate button.

Note:
You can click Generate... without doing Validation before. In this case, it’ll be offered either to make Validation or not.

6. Point out the data source, which contains RDM-schema information to be transferred to JAM. If data source is not specified, generation is canceled. By help of ‘New’ button you can simply create new data source.
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7. Enter JCD name, where JAM widgets and properties will be stored.
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In case of choosen JCD file is not empty the following message will appear:
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If the answer is Yes, then all the objects from the Dictionary will be deleted, and the model will be stored into the empty dictionary with the given name. Otherwise, generation will be canceled.

Note:
All the RDM-schema objects must have their names and coded names, and UDFs values must correspond to one of the acceptable values for one of JAM properties.

The following figure shows the screen with information of conversion of CASE-objects into JCD.
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Validation

After you have selected the parameters, you can verify if the file generated will be valid (accepted by JAM and useable) with the validation function. You should remember that validation will only signal the possible error sources (in data conversion or in RDM objects specifications) without preventing the generation of a bad JCD.

Click on Validation... in the Forward Engineer window, and input the name of the types description file jam_sr.typ and the name of the text file to read about the errors or warnings detected. Once the validation is done and the following message appeared: 
The validation file contains errors and warnings for this schema, 

you should look through the text file. To do this, from the Utility menu, select View a Text File...
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It is recommended to use absolutely correct and valid RDM models when generating JCD Dictionary. The validation is performed upon the description of the Base Types and UDFs, specified in the jam.typ file.

When there is no Name or Coded Name for one of the RDM-Schema objects, the following warning appears:

Name or Coded Name is not specified.
For some object without Coded Name diagnostic message includes its name and the name of the corresponding schema or sub-schema.
In case of Base Types differense from those given in JAM are used, the following warning will be generated:

Incorrect JAM base type is used.
Each Domain from the RDM project must be linked to one of the Base Types. You should take into consideration that for the Domains earlier used in the project, a Base Type must be manually linked to.

If not all Domains have corresponding Base Types, the following warning will appear:

Base Type for Domain is not specified.
Specifying UDFs values you should remember that each JAM property has set of acceptable values. For example, Focus protection field can have only 2 possible values: Yes/No. When different values are detected, the following warning will appear:

Incorrect property value in UDF <property name>.

RDM Specifications transferred to JAM
	SILVERRUN-RDM
	JAM

	Table
	Table View

	Name
	Name

	
	Table

	Column
	Single line text widget

	Name
	Name

	
	Column Name

	Length
	Length

	Null value possible
	Null Field

	Base Type
	

	Name
	C Type

	
	Column Type

	
	Format Type

	
	Keystroke Filter

	Domain
	

	Minimum Value
	Minimum Value

	Maximum Value
	Maximum Value

	Validation Rule
	Edit Mask

	
	Keystroke Filter

	Connector
	Link

	Name
	Name

	Child
	Child

	Direction
	

	Name
	Parent


UDF for DOMAIN and COLUMN:

	UDF names
	JAM property names

	"Widget Type"
	"Widget Type”

	"Hidden"
	"Hidden"

	"Start Row"
	"Start Row"

	"Start Column"
	"Start Column”

	"Focus Protection"
	"Focus Protection"

	"Status Line Text"
	"Status Line Text"

	"Input Protection"
	"Input Protection"

	"Convert Case"
	"Convert Case"

	"Required"
	"Required"

	"Array Size"
	"Array Size"

	"Justification"
	"Justification"

	"FG Color Type"
	"FG Color Type"

	"FG Color Name"
	"FG Color Name"

	“Color Type"
	“Color Type"

	 “Color Name”
	“Color Name”


How to use UDF to assign properties to JAM widgets

Properties for the objects imported to JAM can be specified at the Column level and at the Domain level. Domain level is recommended to use when specifying attributes common to several JAM widgets. In case of specifying property simultaneously at the Domain and Column level, the second definition is used. For example, if Status Line Text for the Key Domain contains Identifier value, the corresponding value will appear for all columns linked to this Domain. However, for each screen this property can be re-specified by assigning another value via UDFs.

Let’s take a simple example of how to transfer JAM widgets properties to SILVERRUN-RDM using UDF. 

For client billing address field from the client table, specify Justification, Convert Case and Status Line Text properties:
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When generating JAM screen, a text widget with the coded name Cli_Bil_Add will be created, and UDFs will be interpreted as JAM properties:
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How to work with JAM CASE ANALYST

In order to import objects from the JCD into JAM, open it using menu File->Open->CASE Dictionary...
Note:
JCD must be within JAM working directory.
[image: image16.png]= Open CASE Dictionary

Tool

SILVERRUN

Dictionary

EMPTY
JCD1
UDF
VIDEO
SAMPLE

Selection

EMPTY@SILVERRUN





Then import CASE objects into JAM widgets using menu File->Import->CASE Object...
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JAM with CASE interface has a CASE Analyst mode, containing the tools for graphic representation of the JAM screen structure, imported from SILVERRUN-RDM.

In such mode the schema of screen widgets looks like this:
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The Figure above shows that the CLI_BIL_ADD field from CLI_Screen1 table was taken for editing. The Justification property is imported from RDM and has the Right value.
In the CASE Analyst mode, you can edit JCD object properties. The bridge Reverse engineering mode allows you to export data from the modified by CASE Analyst JCD to the SILVERRUN-RDM schema.
Note:
It’s important to know you can modify widget properties associated with CASE object attributes only. You should not modify CASE object name widget property.

It’s possible to import tables  from JCD directly to JAM repository. You can use this repository to construct new JAM screens by help of  JAM wizard mode.

Reverse Engineering: From JAM to SILVERRUN-RDM

Procedure

1. Start SILVERRUN-RDM<->JAM. Click on appropriate icon in JYACC group.
2. From the File menu, select Reverse Engineer.
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3. Select the type of the names to be used (Name or Coded Name) and click on the Update button.



4. Select the JCD, containing the information about the JAM widgets to be transferred to the SILVERRUN-RDM schema. If JCD is not specified, RDM updating process is canceled.


5. Select data source, containing information within the files of the chosen DBMS about RDM-schema you want to update. If data source is not specified, RDM updating process is canceled.


The following Figure shows the screen, illustrating the process of updating the RDM-information in the database.


Procedure after updating the model by Reverse Engineering 

Load the model in SILVERRUN-RDM from the chosen DBMS. To do this, perform the following:

1) create a connection to the database, containing information about the updated RDM model, using the menu Util->DBMS->Connections...
2) load the model from the database, using the menu Util->DBMS->Load...
A new model will be created as a result of this operation.

